Back to overview
Downtime

TaxZap Web App Down for Scheduled Maintenance

Jan 14 at 02:06pm GMT
Affected services
TaxZap Web App

Resolved
Jan 14 at 02:07pm GMT

TaxZap Web App maintenance complete.

Created
Jan 14 at 02:06pm GMT

TaxZap web app will be down from 14:00 GMT until 14:10 GMT.